Page 1 of 3 123 LastLast
Results 1 to 5 of 11

Thread: Norton AntiVirus Corporate Edition...

  1. #1
    Join Date
    Jul 2002
    Location
    Lincolnshire, IL
    Posts
    171

    Question Norton AntiVirus Corporate Edition...

    I currently have NAVCE 7.5 installed on a number of systems. I would like to automatically uninstall 7.5 and install 7.6 through my package. I directly edited the NAVCE 7.6 .msi and created a custom action that would do that using the product code.

    The custom action looks like this:

    I created a "New EXE stored in the binary table"

    Executable Filename: {NewBinary2}
    Command Line: /I{BD12EB47-DBDF-11D3-BEEA-00A0CC272509}
    Return Processing: Syncronous (Ignores Exit Code)
    In-Script Execution: Deferred Execution
    Install Exec Sequence: After InstallInitialize

    This doesnt work. I get several different errors.

    Please advise,

    Bryan

  2. #2
    Join Date
    Nov 2002
    Location
    Atlanta
    Posts
    86
    Hey Bryan. Why not go directly to 8.0. I just recently finished creating a nested installation that would install the Installshield Engine (required by Nav 8.0) and that install nav 8.0. I've also tried it on a box that had 7.6 installed. It went in as an upgrade, i did not have to uninstall anything. If you need any details ...let me know.

  3. #3
    Join Date
    Jul 2002
    Location
    Lincolnshire, IL
    Posts
    171

    Norton AntiVirus Corporate Edition

    Dynamox,

    I resolved the issue in a way I didnt expect to. I took the original NAVCE installation which contains a setup.ini. In the cmdline: section I added MsiExec /I{Product Code}. That worked. It uninstalls 7.5 and installs 7.6. I never expected that to work but it did.

    Thanks for the info. Have you seen any benefits in upgrading to 8.0?

    Bryan

  4. #4
    Join Date
    Nov 2002
    Location
    Atlanta
    Posts
    86
    Bryan, so you took this section:

    [Startup]
    CmdLine=
    Product=Norton AntiVirus Corporate Edition
    PackageName=NavCE.Msi
    MsiVersion=1.10.1029.1
    EnableLangDlg=N
    SuppressReboot=Y


    and made it
    CmdLine=MsiExec /I{Product Code}. <- Is this Product code for Nav 7.6 or Nav 7.5 ??
    Interesting..i thought that /i switch was for installation not uninstallation.

    So now, which msi do you run? the one for 7.5 ??

  5. #5
    Join Date
    Jul 2002
    Location
    Lincolnshire, IL
    Posts
    171

    Norton AntiVirus Corporate Edition

    Dynamox,

    That was a typo! :-(

    [Startup]
    CmdLine=
    Product=Norton AntiVirus Corporate Edition
    PackageName=NavCE.Msi
    MsiVersion=1.10.1029.1
    EnableLangDlg=N
    SuppressReboot=Y

    and made it

    CmdLine=MsiExec /x{Product Code}. <- This is the product code for Nav 7.5!

    So... the command line points to the 7.5 installation which gets uninstalled first and then 7.6 gets installed. 7.6 is our corporate standard, another :-(.

    Hope that clears things up, sorry for the delay in my response to you.

    Bryan

Page 1 of 3 123 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •