PDA

View Full Version : Could not find main class com.zerog.lax.Lax



narendhran1
09-30-2009, 12:00 PM
Hi frends,

We are working currently with Installanywhere 8.0.1 enterprise edition,due to some problem i uninstalled and reinstalled Installanywhere. But now when i try to run the build it says ,
It could not find the main class com.zerog.lax.LAX



Its very urgent can anyone help me out plz.

pv7721
09-30-2009, 12:25 PM
On what Windows version does it happen? When you've uninstalled was the IA installation folder completely removed or not? If not, did you manually removed it before reinstalling?

narendhran1
09-30-2009, 12:58 PM
Tanx for ur quick response,

this is happening in Windows XP SP2.. when i uninstalled everything got uninstalled completly...i havent done anything manualy.

pv7721
09-30-2009, 01:22 PM
When you say that everything uninstalled correctly... did you check: did you look in the C:\Program Files in order to make sure that the IA folder was gone?

narendhran1
10-01-2009, 12:39 AM
C:\Program Files\Macrovision\InstallAnywhere 8.0 Enterprise

-->this total path uninstalled correcty

pv7721
10-01-2009, 03:59 AM
Well, in this case for me, the message doesn't make too much sense. It look like an unfinished installation or for I don't know what reason, IA can find its own main class. Could you try before clicking the launching icon to have the CTRL key pressed and see what the console log also says?

narendhran1
10-01-2009, 04:21 AM
Hi pv7721 , i dont know whether i am correct but its working now when i install InstallAnywhere as an administrator,but earlier i installed the same using the USER(Naren) who has administrator rights ..
but tanx for ur kind reply.....

pv7721
10-01-2009, 06:05 AM
Well, most likely the user you were attempting to run IA had trouble accessing the C:\Program Files\IA installation folder. You may want to check the rights on that folder (or even better on the whole C:\Program Files)