PDA

View Full Version : problem in creating Local website in ISS V 5.1



jeyakumar
05-26-2007, 07:17 AM
Hi,
I have created Local website in Windows Xp using Installshield 11.5 premer edition.I copied website content folder to C:\inetpub\wwwroot\.

A.Under Installer website identification details.
I have entered name(NDc8), IP address(I entered my pc IP address) ,TCP port (80),and site number(0).If I want to install other PC Ip address will not work.
so i want to know
1.how to get lnstall PC IP address or .
2.site number I entered '0',is it ok?.
3.Application pools andWeb server Extention any thing I need to enter?

B.Under home directory view
I selected 1."directory located on this computer",2.Localpath (I selected ../wwwroot/website folder.3.application pool(default).

Is it ok?

after installation I found folder is pressent in IIS .but it was not working.

please help me any one how to solve this problem

regards
M.Jeyakumar

davidh
05-29-2007, 09:59 AM
These articles discuss which port number, site number to use:
http://helpnet.macrovision.com/robo/projects/installshield14helplib/IISPortSiteNo.htm
http://support.installshield.com/kb/view.asp?articleid=Q112603

If you are target IIS version 5, you probably don't have to worry about application pools or web service extensions.

jeyakumar
05-30-2007, 06:42 AM
Hi ,
Thanks for your reply.But in that document there is no explanation on Ip address,advanced settings and configuration.I added all files to IISROOTFOLDER .and I configured IIS services as per help document .But after Installation I found there is no Virtual directory for my wesite folder in IIS view. my wedsite folder is present .But I tried manually It is working fine .Under configuration (Application Mapping)I did not enter anything.Please help me anything is required to configure in application mapping and advanced setting.
Note:I am using Installshield 11.5 premier edition and I need to configure IIS V5.1.Please find the attached document.

davidh
05-30-2007, 10:44 AM
I am a little unclear about what you need to happen. Could you perhaps attach your Express project (ise file) to this post?

jeyakumar
05-31-2007, 03:11 AM
divith,
I think I made little confusion on you,sorry for that .My problem is not Creating virutual Directory.I attached project file here.

jeyakumar
05-31-2007, 10:30 AM
Hi ,
How to create Anonymous login in ISS view. I need to update annonymous login like "IUSR_Computername " and password Like "Larsen&Toubro".so that I enterd login name IUSR_[ComputerName] and password "Larsen&Toubro".But this login was not created after installation.Please tell me how to create anonymous login anf password likethat .

regards
jeyakumar.M

davidh
05-31-2007, 10:41 AM
There is no virtual directory in the attached project. There is only a website named NDC8Manager. In the InstallShield IIS view, right click the NDC8Manager website and choose the option to create a 'New Virtual Directory'.

Also, this project appears to not be an Express project, but the behavior in this case should be the same.

davidh
05-31-2007, 10:57 AM
Set the anonymous security information on the appropriate 'Directory Security' tab in the InstallShield IIS view. Make sure you set it on the virtual directory (not the website) if that is where you need it.

jeyakumar
06-05-2007, 12:08 AM
thanks for your help.Now it is creating virtual directory.But while browsing (http://localhost/NDC8Manager/default.aspx)it will not open the web page ,it showing error page. HTTP-404 FILE NOT FOUND.But I checked in inetpub\wwwroot my folder is present .please tell me what I have to do for open like a web page?.

thanks and regards,
Jeyakumar.M

davidh
06-05-2007, 01:34 PM
Maybe start by configuring the virtual directory OUTSIDE of InstallShield. Then, when you solve the error, copy the virtual directory settings to an InstallShield project.