PDA

View Full Version : F-Secure/firewall issue with OnUpdateComplete()?



dmalk1
02-12-2006, 12:43 PM
I'm using InstallShield Express to build my patches and deliver them silently using the Update Service.

A user of mine is encountering an issue with updates installing. The update is downloaded and silent installation begins; however, it never completes yet the OnUpdateComplete() event is triggered. If manually installing the update, it works properly on this same computer. This is why I suspect it's related to Update Service.

My user is running Windows XP w/ F-Secure firewall installed. No other users are having any problems. Here is the F-Secure version details from the problematic computer:

Shaw Secure 5.00 build 760
F-Secure Internet Shield 5.70 build 570
F-Secure Anti-Virus 5.53 build 10440
F-Secure Automatic Update Agent 6.70 build 736
F-Secure Email Scanner 5.60 build 250
F-Secure Management Agent 5.61 build 7670
F-Secure Parental Control 3.00 build 1090
F-Secure Spam Control 1.02 build 1430
F-Secure User Interface 5.70 build 1381

Are there any known firewall conflicts like this? Has anyone else experienced this?

Thanks for the help!
Damon

dmalk1
02-12-2006, 03:26 PM
I'm unsure whether this is of any relevance, but I wanted to note that this user is a Canadian resident and that his Windows XP regional settings are set to "English (Canada)". I thought to mention this because those regional settings cause the short date on the computer to use the format, "DD/MM/YYYY" instead of "MM/DD/YYYY", which is the format we use in Update Service.